Friday 19th October 2018

Customer Websites FarmCentric Customer Websites Down

An operational issue has caused FarmCentric Customer Websites to go down. We have identified the issue and expect them to be online within the next 10-15 minutes.

Update: sites are up but they may be partially degraded. We are working on restoring full functionality.

Update: services have been fully restored.