Monday 3rd June 2019

Push Notifications eSign Feature failing to load files

update 6.4.19 3:50 p.m. The bug preventing files being uploaded or downloaded, affecting the eSign feature has been resolved. eSign is now functioning as intended.

Update 6.4.19. 11:45 a.m. We have Identified the root cause of the problem. We are exploring possible solutions. We provide an additional update this afternoon.

Update 6.4.19 9:00 am We are continuing our investigation into this issue. We will continue to provide updates throughout today.

We are investigating an issue causing Bushel Admin tool user's to be unable to upload contracts to be sent via the eSign feature.