Thursday 25th July 2019

AgTrax Updates Delayed.

UPDATE Fixed

We have become aware of an issue affecting some Bushel-powered Apps. This incident is affecting companies that work with AgTrax. We are aware of and investigating the delay of the Commodity Balance feature updating for some users. This is also occurring with tickets and contracts intermittently. We will continue to provide updates as we work to mitigate this incident.

If you have further questions or concerns please send them to support@bushelpowered.ag

UPDATE: Issues with AgTrax updates appear to be resolved. We will continue to watch and monitor for any further issues.