Wednesday 2nd May 2018

Networking Outage

Update 3: Our service provider has resolved the issue and all services are operating normally.

Update 2: Services are recovering, we'll continue to watch the situation.

Update: Our service provider has confirmed the outage and is working to fix it.

Our service provider is currently having networking issues, we will provide updates as they become available to us.