Monday 24th February 2020

Futures currently not updating *Resolved*

update 2-24-20 10:31:00 A.M. (CT) The issue is now resolved. Future Feeds are updating as intended

update We are aware this issue is due to our feed provider is experiencing an issue. We are in communication with them and working together toward a resolution.

We have become aware of an issue affecting all Bushel-powered Apps, and websites. This incident is affecting futures feed. We are aware the feed is not updating. We are currently investigating the issue. We will continue to provide updates as we work to mitigate this issue. If you have any questions or concerns please contact us at support@bushelpowered.com or visit our support page https://support.bushelpowered.com/