Resolved. Cash Bid Performance Issues Wednesday 2nd October 2019 20:30:00


UPDATE 10/3/19 As of last night (10/2/19) our team has corrected the Cash bid performance issues. We appreciate your patience during this incident and apologize for any inconvenience or frustration caused.

-Your Bushel Team